51Nod 1432 独木舟 (贪心

1432 独木舟

Description

n个人,已知每个人体重。独木舟承重固定,每只独木舟最多坐两个人,可以坐一个人或者两个人。显然要求总重量不超过独木舟承重,假设每个人体重也不超过独木舟承重,问最少需要几只独木舟?

Input

第一行包含两个正整数n (0

Output

一行一个整数表示最少需要的独木舟数。

Sample Input

3 6
1
2
3

Sample Output

2

题解:

明确思路后就会发现比较水的贪心了的(才开始思路错了
升序排列 把数组内最大与最小的加起来 > m 的话将最大那个去除k+1
继续加 就会得到最少的船了QAQ

AC代码

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define ll long long
const int mod = 1e9+7;
const int N = 10010;
int arr[N]; 
int main()
{
    int n, m;
    scanf("%d%d",&n,&m);
    for(int i = 0;i < n; i++) {
        scanf("%d",&arr[i]);
    }
    sort(arr,arr+n);
    int j = n-1;
    int i = 0, k = 0;;
    while(i <= j) {
        if(arr[i]+arr[j]<=m) {
            k++;
            i++;j--;
        }
        else {
            k++;
            j--;
        }
    }
    printf("%d\n",k);
return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值