Codeforces 803 A. Maximal Binary Matrix (模拟

A. Maximal Binary Matrix

Description

You are given matrix with n rows and n columns filled with zeroes. You should put k ones in it in such a way that the resulting matrix is symmetrical with respect to the main diagonal (the diagonal that goes from the top left to the bottom right corner) and is lexicographically maximal.

One matrix is lexicographically greater than the other if the first different number in the first different row from the top in the first matrix is greater than the corresponding number in the second one.

If there exists no such matrix then output -1.

Input

The first line consists of two numbers n and k (1 ≤ n ≤ 100, 0 ≤ k ≤ 106).

Output

If the answer exists then output resulting matrix. Otherwise output -1.

Sample Input

2 1
3 2

Sample Output

1 0 
0 0 
1 0 0 
0 1 0 
0 0 0 

题意

给您一个矩阵 和一个数字k问您是否能完全填充
填充规则按照字典序(从上到下)和中轴线对称的方法

题解:

一直没理解字典序是什么意思 后来想想就是按照从上到下的原则填充啊
我果然是个脑残

AC代码

#include <bits/stdc++.h>
using namespace std;
#define N 1000
int vis[N][N];
int main()
{
    int n, k;
    memset(vis,0,sizeof(vis));
    scanf("%d%d",&n,&k);
    bool flag = true;
    if(k > n*n) flag = false;
    else {
        for(int i = 0;i < n; i++) {
            for(int j = 0;j < n; j++) {
                if(vis[i][j]) continue;
                else if(i==j && k!=0) {
                    vis[i][j] = 1; k--;
                }
                else if (k>=2){
                    vis[i][j] = vis[j][i] = 1;
                    k -= 2;
                }   
            }
        }
        if(k) flag = false;
    }
    if(flag) {
        for(int i = 0;i < n; i++) {
            for(int j = 0;j < n; j++) {
                if(j==0) printf("%d",vis[i][j]);
                else printf(" %d",vis[i][j]);
            }
            printf("\n");
        }
    }
    else puts("-1");
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值