Codeforces Round #201 (Div. 2) C. Alice and Bob ( 数学

C. Alice and Bob

Description

It is so boring in the summer holiday, isn’t it? So Alice and Bob have invented a new game to play. The rules are as follows. First, they get a set of n distinct integers. And then they take turns to make the following moves. During each move, either Alice or Bob (the player whose turn is the current) can choose two distinct integers x and y from the set, such that the set doesn’t contain their absolute difference |x - y|. Then this player adds integer |x - y| to the set (so, the size of the set increases by one).

If the current player has no valid move, he (or she) loses the game. The question is who will finally win the game if both players play optimally. Remember that Alice always moves first.

Input

The first line contains an integer n (2 ≤ n ≤ 100) — the initial number of elements in the set. The second line contains n distinct space-separated integers a1, a2, …, an (1 ≤ ai ≤ 109) — the elements of the set.

Output

Print a single line with the winner’s name. If Alice wins print “Alice”, otherwise print “Bob” (without quotes).

Sample Input

2
2 3
2
5 3
3
5 6 7

Sample Output

Alice
Alice
Bob

Hint

Consider the first test sample. Alice moves first, and the only move she can do is to choose 2 and 3, then to add 1 to the set. Next Bob moves, there is no valid move anymore, so the winner is Alice.

题意

给一组数 两个依次从中间分别拿出两个数下x, y 获得新的数字 z=|x-y| 如果数组里面没有这个数就扔进去 直到有一个人找不出新的数字z 怎输出这个他的名字

题解

博弈问题转数学问题 经过观察可以发现 如果这个数据的最终状态就是 以公差为首项等差数列的 所以 只要将最终的项数-n就是操作数

AC代码

#include <bits/stdc++.h>
using namespace std;

typedef long long LL;
const int N = 1e3;
int arr[N];

int gcd(int a, int b)
{
    if(b == 0) return a;
    return gcd(b,a%b);
}

int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0;i < n; i++) {
        scanf("%d",&arr[i]);
    }
    sort(arr,arr+n);
    int res = arr[0];
    for(int i = 1;i < n; i++) {
        res = gcd(res,arr[i]);
    }
    int ans = arr[n-1]/res - n;
    if(ans&1) puts("Alice");
    else puts("Bob");
return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值