Codeforces Round 22 C. The Tag Game ( 搜索

C. The Tag Game

Description

Alice got tired of playing the tag game by the usual rules so she offered Bob a little modification to it. Now the game should be played on an undirected rooted tree of n vertices. Vertex 1 is the root of the tree.

Alice starts at vertex 1 and Bob starts at vertex x (x ≠ 1). The moves are made in turns, Bob goes first. In one move one can either stay at the current vertex or travel to the neighbouring one.

The game ends when Alice goes to the same vertex where Bob is standing. Alice wants to minimize the total number of moves and Bob wants to maximize it.

You should write a program which will determine how many moves will the game last.

Input

The first line contains two integer numbers n and x (2 ≤ n ≤ 2·105, 2 ≤ x ≤ n).

Each of the next n - 1 lines contains two integer numbers a and b (1 ≤ a, b ≤ n) — edges of the tree. It is guaranteed that the edges form a valid tree.

Output

Print the total number of moves Alice and Bob will make.

Sample Input

4 3
1 2
2 3
2 4
5 2
1 2
2 3
3 4
2 5

Sample Output

4
6

Hint

In the first example the tree looks like this:

The red vertex is Alice’s starting position, the blue one is Bob’s. Bob will make the game run the longest by standing at the vertex 3 during all the game. So here are the moves:
这里写图片描述
B: stay at vertex 3

A: go to vertex 2

B: stay at vertex 3

A: go to vertex 3

In the second example the tree looks like this:

这里写图片描述
The moves in the optimal strategy are:

B: go to vertex 3

A: go to vertex 2

B: go to vertex 4

A: go to vertex 3

B: stay at vertex 4

A: go to vertex 4

题意

有一棵n个节点n-1条边的树,小A和小B在树上玩一个游戏。初始时小A在点1,小B在点x。

两人轮流操作,小B先手,每一次操作两人可以移动向一个相邻的节点或者不动。现在小A想要尽快使得自己和小B在同一个格子里,而小B想要尽量晚和小A在同一个格子里。假设两人足够聪明,问几步之后两人在同一个格子里(两人步数和)。

题解:

两次dfs 第一次把 第一个人所以走的距离纪律下来
第二次同样操作 、当他们距离相同就是 走到同一个人地方
否则 继续跑

AC代码

#include <bits/stdc++.h>
using namespace std;

#define LL long long
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define root 1 , N , 1
/* -------------------------------------- */
inline bool scan_d(int &num)
{
        char in;bool IsN=false; in=getchar(); if(in==EOF) return false;
        while(in!='-'&&(in<'0'||in>'9')) in=getchar();
        if(in=='-'){ IsN=true;num=0;} else num=in-'0';
        while(in=getchar(),in>='0'&&in<='9'){ num*=10,num+=in-'0';}
        if(IsN) num=-num;   return true;
}
/*
  #pragma comment(linker, "/STACK:102400000,102400000")
  C++
  ---------------------------------------
    int size = 256 << 20; // 256MB
    char *p = (char*)malloc(size) + size;
    __asm__("movl %0, %%esp\n" :: "r"(p));
    G++
*/
/* -------------------------------------- */

const int  N =2e6;
vector<int> v[N];
int dis[2][N];
int ans;

void dfs(int x,int y,int z,int vis)
{

    dis[z][x] = vis;
    if(z==1 && dis[0][x]==vis) {
        ans = max(vis,ans);
        return;
    }
    if(z==1 && vis<dis[0][x]) {
        ans = max(ans,dis[0][x]*2);
    }
    for(int i = 0;i < v[x].size(); i++) {
        int res = v[x][i];
        if(res == y) continue;
        dfs(res,x,z,vis+1);
    }
}

int main()
{
    ios::sync_with_stdio(false);
    int n, x;
    cin>>n>>x;
    ans = 0;
    for(int i = 0;i < n-1; i++) {
        int x, y;
        cin>>x>>y;
        v[x].push_back(y);
        v[y].push_back(x);
    }
    dfs(1,-1,0,0);
    dfs(x,-1,1,0);
    cout<<ans<<endl;

return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值