Poj 1847 Tram ( 最短路变形

Tram

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

题意

很有意思的一道题 问 火车默认拐道节点为0 也就是 第一个 别的为1就好 请最短路

题解:

忘记不存在的情况了 wa了一发 ZZ

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))

const int INF = 0x3f3f3f3f;
const LL INFLL = 0x3f3f3f3f3f3f3f3f;
const int N = 1e3+10;
int mps[N][N];       //邻接矩阵,表示从->的距离
int dis[N];       //dst[i] 从到i的距离
bool vis[N];      // 标记节点是否被访问'
int n, m;
int s, t;
void Dijkstra()
{
    for(int i = 1;i <= n; i++) dis[i] = mps[s][i];
    dis[s] = 0;
    vis[s] = true;
    int minx, k;
    for(int i = 1;i <= n; i++) {
        minx = INF;
        for(int j = 1;j <= n; j++) {
            if(!vis[j] && minx>dis[j]) {
                minx = dis[j];
                k = j;
            }
        }
        if(minx == INF) break;
        vis[k] = true;
        for(int j = 1; j <= n; j++) {
            if(!vis[j] && dis[j] > dis[k]+mps[k][j]) {
                dis[j] = dis[k]+mps[k][j];
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d%d",&n,&s,&t)) {
        CLR(vis,false);
        CLR(dis,0);
        int x, y, z;
        for(int i = 1;i <= n; i++) {
            for(int j = 1;j <= i; j++) {
                if(i == j) mps[i][j] = 0;
                else mps[i][j] = mps[j][i] = INF;
            }
        }
        int a, b;
        for(int i = 1; i <= n; i++) {
            scanf("%d",&a);
            for(int j = 0;j < a; j++) {
                scanf("%d",&b);
                if(j == 0) mps[i][b] = 0;
                else mps[i][b]  = 1;
            }
        }
        Dijkstra();
        if(dis[t] == INF)
            printf("-1\n");
        else
            printf("%d\n",dis[t]);

    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值