ICPC2017南宁邀请赛1005&&HDU6197 (模拟

CS Course

Description

Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.

Input

There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤105

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤109 for each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin q lines, 1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.

Sample Input

3 3
1 1 1
1
2
3

Sample Output

1 1 0
1 1 0
1 1 0

题意

给一组数 再给一个数求除了这个数的所有数的&,|,^,
因为是静态的查询, 直接统计前缀后缀就ok

AC代码

#include <bits/stdc++.h>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))

const int MAXM = 1e3+10;
const int MAXN = 1e6+10;

int arr[MAXN];
int sa[MAXN], sb[MAXN], sc[MAXN];
int ea[MAXN], eb[MAXN], ec[MAXN];

int main()
{
    int n, q;
    while(~scanf("%d%d",&n,&q)) {
        for(int i = 1; i <= n; i++) {
            scanf("%d",&arr[i]);
        }
        sa[1] = sb[1] = sc[1] = arr[1];
        ea[n] = eb[n] = ec[n] = arr[n];
        for(int i = 2; i <= n; i++) {
            sa[i] = sa[i-1]&arr[i];
            sb[i] = sb[i-1]|arr[i];
            sc[i] = sc[i-1]^arr[i];
        }
        for(int i = n-1; i >= 1; i--) {
            ea[i] = ea[i+1]&arr[i];
            eb[i] = eb[i+1]|arr[i];
            ec[i] = ec[i+1]^arr[i];
        }
        int x;
        while(q--) {
            scanf("%d",&x);
            if(x == 1) {
                printf("%d %d %d\n",ea[x+1],eb[x+1],ec[x+1]);
            }
            else if(x == n) {
                printf("%d %d %d\n",sa[x-1],sb[x-1],sc[x-1]);
            }
            else {
                printf("%d %d %d\n",sa[x-1]&ea[x+1],sb[x-1]|eb[x+1],sc[x-1]^ec[x+1]);
            }
        }
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值