POJ 2247 Maximum sum ( dp

Maximum sum

题目描述

Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

Your task is to calculate d(A).

输入

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.

输出

Print exactly one line for each test case. The line should contain the integer d(A).

样例

Sample Input
1

10
1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13


Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

题意

最大字段和问题的简单延伸 思想类似与折半搜索的感觉

AC代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))
const int INF = 0x3f3f3f3f;
const int mod = 1e9+7;
const int MAXN = 1e5+10;

int arr[MAXN];
int dp[MAXN];  // dp[i] 表示的状态就是以arr[i]为结尾的最大子段和的大小
int rr[MAXN], ll[MAXN];
int main() {
   // ios::sync_with_stdio(false);
    int T;
    cin >> T;
    while(T--) {
        CLR(arr,0);
        CLR(dp,0);
        int n;
        cin >> n;
        for(int i = 1; i <= n; i++)
            scanf("%d",&arr[i]);
        dp[0]  = -INF;
        rr[n+1] = ll[0] = -INF;
        for(int i = 1; i <= n; i++)
            dp[i] = max(dp[i-1]+arr[i], arr[i]);
        for(int i = 1; i <= n; i++)
            ll[i] = max(dp[i], ll[i-1]);
        CLR(dp,0), dp[n+1] = -INF;
        for(int i = n; i >= 1; i--)
            dp[i] = max(dp[i+1]+arr[i], arr[i]);
        for(int i = n; i >= 1; i--)
            rr[i] = max(rr[i+1],dp[i]);
        int ans = -INF;
        for(int i = 1; i <= n; i++)
            ans = max(ans, ll[i]+rr[i+1]);
        cout << ans << endl;
     }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值