Cat VS Dog

Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
  
  
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

Sample Output
  
  
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy. 题解:要求求出最多开心的孩子,意思就是让尽量多拿走不喜欢的动物。但是由于这个不喜欢的也许是别人喜欢的,这时候就必须选其中 一个,总不能都不选吧,这样就没有孩子开心了。这些孩子是矛盾的。所以将矛盾的孩子用边连接起来。再求出最多对矛盾的孩子,既最大匹配, 然后求最大独立集得到的孩子就不矛盾了,就可以把他们不喜欢的动物拿走,因为他们之间不矛盾。得到的就是最多开心的孩子。
#include <iostream>
#include <cstdio>
#include <cstring> 
#include <map>
#include <vector>

using namespace std;

vector<int> vec[505];
char like[503][20];
char dis[503][20];
bool visited[505];
int pre[505];

bool find(int x)
{
	for(int i = 0;i < vec[x].size();i++)
	{
		int t = vec[x][i];
		if(!visited[t])
		{
			visited[t] = true;
			if(pre[t] == 0 || find(pre[t]))
			{
				pre[t] = x;
				return true;
			}
		}
	}
	
	return false;
}

int main()
{
	int n,m,p;
	while(scanf("%d%d%d",&n,&m,&p) != EOF)
	{
		for(int i = 1;i <= p;i++)
		{
			scanf("%s%s",like[i],dis[i]);
		}
		for(int i = 1;i <= p;i++)
		{
			for(int j = i + 1;j <= p;j++)
			{
				if(strcmp(dis[i],like[j]) == 0 || strcmp(like[i],dis[j]) == 0)
				{
					vec[i].push_back(j);
					vec[j].push_back(i);
				}
			}
		}
		
		memset(pre,0,sizeof(pre));
		int ans = 0;
		for(int i = 1;i <= p;i++)
		{
			memset(visited,false,sizeof(visited)); 
			if(find(i))
			{
				ans++;
			}
		}
		
		printf("%d\n",p - ans / 2);
		for(int i = 1;i <= p;i++)
		{
			vec[i].clear();
		}
		
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值