Billboard

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1


题解:按照题目要求,每次放在最上边和最左边,你可以贪心去做,但是时间复杂度太大。用线段树刚好符合题目要求,把每个叶子节点从左到右当成高为1,2,3.....h的位置,父节点表示左右孩子空间最大的一个,但是优先考虑左孩子。正好符合题意,查询时间复杂度变成了logn(树的最大深度就是logn)。


#include <iostream>
#include <cstdio>
#include <cstring>
#define mem(a) memsize(a,0,sizeof(a));

using namespace std;

int v[8000006];

int max(int a,int b)
{
	return a > b ? a : b;
}

void segTree(int k,int l,int r,int w)  //每一个高度长起始值都是w 
{
	v[k] = w;
	if(l == r)
	{
		return;
	}
	int mid = ( l + r) >> 1;
	segTree(k << 1,l,mid,w);
	segTree((k << 1) | 1,mid + 1,r,w);
}

void pushUp(int k)     //更新父节点 
{
	v[k] = max(v[k << 1],v[(k << 1) | 1]);
}

void query(int k,int x,int l,int r)
{
	if(l == r)
	{
		v[k] -=x;
		printf("%d\n",l);
		return;
	}
	int mid = (l + r) >> 1;
	if(x <= v[k << 1])
	{
		query(k << 1,x,l,mid);
	}
	else
	{
		query((k << 1) | 1,x,mid + 1,r);
	}
	
	pushUp(k);
}

int main()
{
	int h,w,n;
	while(scanf("%d%d%d",&h,&w,&n) != EOF)
	{
		int wi;
		if(h > n)       //这里很重要,贴的最多为n条,但是当h < n时,如果开区间为1-n,就 
		{               //多了,但是开1-h数组又会太大。所以取小的一个 
			h = n;
		}
		segTree(1,1,h,w);
		for(int i = 0;i < n;i++)
		{
			scanf("%d",&wi);
			if(wi > v[1])
			{
				printf("-1\n");
				continue;
			}
			query(1,wi,1,h);
		}
	}
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值