Ancient Printer



Problem Description
The contest is beginning! While preparing the contest, iSea wanted to print the teams' names separately on a single paper.
Unfortunately, what iSea could find was only an ancient printer: so ancient that you can't believe it, it only had three kinds of operations:

● 'a'-'z': twenty-six letters you can type
● 'Del': delete the last letter if it exists
● 'Print': print the word you have typed in the printer

The printer was empty in the beginning, iSea must use the three operations to print all the teams' name, not necessarily in the order in the input. Each time, he can type letters at the end of printer, or delete the last letter, or print the current word. After printing, the letters are stilling in the printer, you may delete some letters to print the next one, but you needn't delete the last word's letters.
iSea wanted to minimize the total number of operations, help him, please.
 

Input
There are several test cases in the input.

Each test case begin with one integer N (1 ≤ N ≤ 10000), indicating the number of team names.
Then N strings follow, each string only contains lowercases, not empty, and its length is no more than 50.

The input terminates by end of file marker.
 

Output
For each test case, output one integer, indicating minimum number of operations.
 

Sample Input
  
  
2 freeradiant freeopen
 

Sample Output
 
 
21


题解:要想得到最少就要操作最少,所以对于有公共前缀的字符串,前缀只打印一次。首先我们把所有字符串用字典树保存。此时这棵树的每一个节点都要打印,除了根(不包含字母),现在所有节点都要打印和删除,但是最后一个字符串不删除,该字符串肯定是最长的了。所以公式=res=2 * (n (节点数)- 1) + m(打印次数) - maxlen(最长字符串)。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct Node
{
	Node* next[26];
	Node()
	{
		for(int i = 0;i < 26;i++)
		{
			next[i] = NULL;
		}
	}
};

int res = 0;
Node* root;

int max(int a,int b)
{
	return a > b ? a : b;
}

void insert(char* s)
{
	Node* p = root;
	int len = strlen(s);
	for(int i = 0; i < len;i++)
	{
		int x = s[i] - 'a';
		if(p->next[x] == NULL)
		{
			Node* q = new Node();
			p->next[x] = q;
			res++;
		}
		p = p->next[x];
	}
}

void del(Node*& root)
{
	for(int i = 0; i < 26;i++)
	{
		if(root->next[i] != NULL)
		{
			del(root->next[i]);
		}
	}
	
	delete root;
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF)
	{
		root = new Node();
		char s[100];
		res = 0;
		int maxlen = 0;
		for(int i = 0;i < n;i++)
		{
			scanf("%s",s);
			maxlen = max(maxlen,strlen(s));
			insert(s);
		}
		res = 2 * res + n - maxlen;
		printf("%d\n",res);
		
		del(root);
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值