小球装箱游戏

image.png

输入格式:

image.png

输出格式:

image.png

image.png

image.png

image.png

输入样例:

6
1 1
3 0
2 1
4 1
6 0
5 0

输出样例:

2 1
1 2

 

#include<bits/stdc++.h>
using namespace std;
typedef struct
{
    int size;
    int color;
}ball;
bool cmp(ball x,ball y){
    if(x.size!=y.size) return x.size>y.size;
    else return x.color<y.color;
}
int main()
{
    int n,m,A0=0,A1=0,B0=0,B1=0;
    ball p[100001];
    cin>>n;
    m=n/2;
    for(int i=0;i<n;i++)
        cin>>p[i].size>>p[i].color;
    sort(p,p+n,cmp);
    for(int i=0;i<n;i++){
        if(i<m){
                if(p[i].color==0) A0++;
                else A1++;
            }
        else {
            if(p[i].color==0) B0++;
            else B1++;
        }
    }
    cout<<A0<<" "<<A1<<endl;
    cout<<B0<<" "<<B1;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值