zzulioj-1915-H(水题)

题目连接:点击打开链接

1915: H

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 284   Solved: 120

Submit Status Web Board

Description

在三维空间里,晴天得到了一些坐标,然后他想知道这些坐标有没有重合的哇,然后若两个坐标是重合的也就是x=x,y=y,z=z。然后他把这个任务交给你啦。

Input

输入第一行包含一个整数t表示有多少组数据。
每组数据一个整数n,表示有多少个点。
接下来n行,每行有三个整数x,y,z表示一个点的坐标.
0<=n<=200000,0<=x,y,z<100,t<=20

Output


若有两个点重合输出yes,否则输出no

Sample Input

1
3
1 1 1
1 2 1
1 1 1

Sample Output

yes

水题,尼玛还看了好长时间,最后昏了头写那么长的代码过的。回来头再一看,x,y,z 那么小,开个三维数组就直接水了啊,我个 ZZ.........

之前的ZZ代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX=2e5+10;
int n;
struct node
{
	int x,y,z;
}a[MAX];
bool cmp(node p,node q)
{
	if(p.x!=q.x)
		return p.x<q.x;
	else
	{
		if(p.y!=q.y)
			return p.y<q.y;
		else
			return p.z<q.z;	
	}
}
int mark[MAX];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].z);
		}
		sort(a,a+n,cmp);
		bool flag=0;
		for(int i=1;i<n;i++)
		{
			if(a[i].x==a[i-1].x)
			{
				if(a[i].y==a[i-1].y)
				{
					if(a[i].z==a[i-1].z)
					{
						flag=1;
					}
				}
			}
		}
		if(flag)	printf("yes\n");
		else	printf("no\n");
	}
	return 0;
}

后来的:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
int map[110][110][110];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(map,0,sizeof(map)); 
		bool flag=0;
		int a,b,c;
		while(n--)
		{
			scanf("%d %d %d",&a,&b,&c);
			map[a][b][c]++;
			if(map[a][b][c]>1)
			{
				flag=1;
			}
		}
		if(flag)	printf("yes\n");
		else	printf("no\n");
	}
	return 0;
}

再来一个二维数组的 :

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
int vis[110][110];  
int main()  
{  
    int t,n,a,b,c,i,j,k;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d",&n);  
        int flag=0;  
        memset(vis,-1,sizeof(vis));  
        for(i=0;i<n;i++)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            if(vis[a][b]!=-1&&vis[a][b]==c)  
            {  
                flag=1;  
            }  
            else vis[a][b]=c;  
        }  
        if(flag==0)  
        printf("no\n");  
        else printf("yes\n");  
    }  
    return 0;  
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值