HDU-1002-A + B Problem II【大数】

题目链接:点击打开链接

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 317834    Accepted Submission(s): 61762


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int numa[1010],numb[1010];
char a[1010],b[1010];
int main()
{
    int t,text=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(numa,0,sizeof(numa));
        memset(numb,0,sizeof(numb));
        scanf("%s %s",a,b);
        printf("Case %d:\n%s + %s = ",++text,a,b);
        int alen=strlen(a);
        int blen=strlen(b);
        for(int i=0;i<alen;i++)
            numa[alen-1-i]=a[i]-'0';
        for(int i=0;i<blen;i++)
            numb[blen-1-i]=b[i]-'0';
        int len=max(alen,blen);
        for(int i=0;i<len;i++)
        {
            numa[i]=numa[i]+numb[i];
            if(numa[i]>9)
            {
                numa[i]-=10;
                numa[i+1]++;
            }
        }
        if(numa[len]!=0)    printf("%d",numa[len]);
        for(int i=len-1;i>=0;i--)
            printf("%d",numa[i]);
        puts("");
        if(t)    puts("");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值