Primes
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12483 Accepted Submission(s): 5171
Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.
Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".
Sample Input
1
2
3
4
5
17
0
Sample Output
1: no
2: no
3: yes
4: no
5: yes
6: yes
个人理解:
1.在题目中我们应该注意题目中对输出格式的要求,按要求输出;
2.定义prime()函数,得到返回值,带入main()中,由返回值判断输入值是否为素数。
代码:
# include <stdio.h>
# include <math.h>
int prime(int n);
int main(){
int n,i=1;
scanf("%d",&n);
while(n>0)
{
printf("%d: %s\n",i++,prime(n)?"yes":"no");
scanf("%d",&n);
}
return 0;
}
int prime(int n)
{
int i,b=sqrt(n);
for(i=2;i<=b;i++)
if(n%i==0)return 0;
if(n==2||n==1) return 0;
return n;
}