2017杭电多校联赛第三场-RXD and math (hdu6063) 找规律快速幂

RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 418    Accepted Submission(s): 212
Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module  109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk  are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers  n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
  
  
10 10
 

Sample Output
  
  
Case #1: 999999937
 

Source

题目大意:给你一个如上的公式,然后给你 n 和 k 的值,询问代入公式得到的结果。

解题思路:我们注意到 n 和 k  的数据范围都是 10^18 ,所以一旦涉及到关于求u(i) 的值的想法都是不可能实现的,所以我们就不能去利用莫比乌斯函数去具体求值,所以这个时候我们就需要去打表看当n 和 k 值取不同值时的结果,结果发现结果就是n^k.

ac代码:
#include <iostream>
#include <cstdio>
using namespace std;
#define ll long long
#define maxn 1000000007
ll power2(ll a, ll b, ll c)//fast_power
{
    ll res = 1;
    a %= c;
    while (b)
    {
        if (b & 1)
            res = (res * a) % c;
        a = (a * a) % c;
        b >>= 1;
    }
    return res;
}
int main()
{
	int cas=1;
	ll a,b;
	while(scanf("%lld%lld",&a,&b)!=EOF)
	{
		printf("Case #%d: %lld\n",cas++,power2(a,b,maxn));
	}
	return 0;
}

题目链接: 点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=6063







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值