hdu6103-Kirinriki (2017杭电多校联赛第6场)

Kirinriki

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 796    Accepted Submission(s): 306


Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.
 

Sample Input
  
  
1 5 abcdefedcb
 

Sample Output
  
  
5
Hint
[0, 4] abcde [5, 9] fedcb The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5
 

Source


题目大意:给你一个计算两个相同长度的计算公式,每两个相同长度的字符串会得到一个值,现在给你一个字符串,然后给你一个值,询问在这个字符串中得到这个值的两个字符串的最大距离差。

解题思路:我们枚举每个位置,然后往两边寻找,暴力枚举每个位置得到最大值。

ac代码如下:
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
const int N=50005;
int n,m,ans;
int q[N],p[N];
char s[N];
void cal(int l,int r){
    int x,y,v;
    x=y=v=0;
    q[y]=0;
    p[y]=r-1;
    y++;
    while(l>=0&&r<n){
        v+=abs(s[r]-s[l]);
        q[y]=v;
        p[y]=r;
        y++;
        while(v-q[x]>m)x++;
        ans=max(ans,r-p[x]);
        l--,r++;
    }
}
int main(){ 
    int T;
    int i;
    scanf("%d",&T); 
    while(T--){
        scanf("%d",&m);
        scanf("%s",s);
        n=strlen(s);
        ans=0;
        for(i=1;i<n;i++){
            cal(i-1,i);
            cal(i-2,i);
        } 
        printf("%d\n",ans);
    }
    
    return 0;
}

题目链接:点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=6103
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值