Big Number

Problem Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10[sup]7[/sup] on each line.

Output The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input2
10
20

Sample Output7
19

#include<stdio.h>
#include<math.h>
int main()
{
 int t,n;
 scanf("%d",&t);
 while(t--)
 {
  double s=0;
  scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
   s+=log10(i);
  }
  printf("%d\n",(int)s+1);//转换成整形,省去小数点后面的 
 }
 return 0;
 } 

第一次用平常的方法发现根本数字太大过不了,最后又学到用数学库里面的函数log10来解决位数的问题。。。先通过循环算出log10(1)+…+log10(10)=log10(123…*10),再加上一即可得出位数(由于后面有小数点)最后输出时进行类型转换即可输出答案。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值