HDU 1241 Oil Deposits

搜索第二题,经典dfs~


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17295    Accepted Submission(s): 9965


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source

题目链接:HDU1241 Oil Deposits

题意很简单,输入两个整数m n,表示一个m行n列的油田,由输入的*和@组成,相连的@为一块油田(相连指8个方向相连,即上、下、左、右、左上、左下、右上、右下),求出一共有多少块油田。


#include <cstdio>
#include <iostream>
using namespace std;
char maze[105][105];
int m,n,sum;

void dfs(int i,int j)
{
    if(maze[i][j]!='@' || i<0 || j<0 || i>=m || j>=n)    //如果不可以通过,或越界,返回
        return;
    else
    {
        maze[i][j]='!';    //否则,向8个方向深搜。并且标记该点已通过,即下次不可行
        dfs(i+1,j);
        dfs(i-1,j);
        dfs(i,j+1);
        dfs(i,j-1);
        dfs(i+1,j+1);
        dfs(i+1,j-1);
        dfs(i-1,j+1);
        dfs(i-1,j-1);
    }
}

int main()
{
    while(cin>>m>>n)
    {
        sum=0;
        if(m==0||n==0)
            break;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                cin>>maze[i][j];    //开始用scanf("%c",&maze[i][j]); 会吞回车。
            }
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                if(maze[i][j]=='@') //如果可以通过,dfs。dfs一遍后sum+1,即找到一块油田
                {
                    dfs(i,j);
                    sum++;
                }
            }
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值