HDU 5326 Work 并查集 (2015 Multi-University Training Contest 3 2015多校联合)

-_- 好吧我不得不承认这道题是签到题。

这道题方法很多,可以用dfs等等,我是用并查集做的。思路很简单,就是求管理k个人的人数有多少。

就是先用一个数组pre来表示该节点的父节点,初始化都为自己,输入的时候直接录入,然后查找,直到找到父节点是自己的结点为止,这样就可以求出每个结点下边的子孙结点有多少个,直接和题目给的数字比较一下然后累加就可以了。

看着代码自己感悟吧。~

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 784    Accepted Submission(s): 504


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2
 

Author
ZSTU
 

Source

题目链接:HDU5326 Work

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
using namespace std;
int  pre[105];
int t[105];
void find(int x)
{
    if(x!=pre[x])
    {
        t[pre[x]]++;
        find(pre[x]);
    }
    else
        return ;
}
int main()
{
    int n,k,x,y,ans,i;
    while(~scanf("%d%d",&n,&k))
    {
        ans=0;
        for(i=0;i<=n;i++)
            pre[i]=i;
        memset(t,0,sizeof(t));
        for(i=1;i<=n-1;i++)
        {
            scanf("%d%d",&x,&y);
            pre[y]=x;
        }
        for(i=1;i<=n;i++)
        {
            if(pre[i]==i)
                continue;
            else
                find(i);
        }
        for(i=1;i<=n;i++)
        {
            if(t[i]==k)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值