HDU 5363 Key Set(2015 Multi-University Training Contest 6 2015多校联合)

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 476    Accepted Submission(s): 251


Problem Description
  
  
soda has a set S with n integers {1,2,,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.
 

Input
  
  
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case: The first line contains an integer n (1n109) , the number of integers in the set.
 

Output
  
  
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
0 1 3 7
 

题目传送门: HDU 5363 Key Set
规律很容易找到。ans=pow(2,n-1)-1。但是pow到2^62就会爆。所以方法就是改写一下pow函数。然后在计算过程中%MOD。
用高精度幂运算模板过就行了。
注意输入1的时候,代码会爆栈。所以要用一个if。
代码:
#include <cstdio>
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
long long mypow(long long x, long long y)
{
	if (y == 1) return x;
	long long int result = 0;
	long long int tmp = mypow(x, y / 2) % 1000000007;
	if (y & 1 != 0)
	{
		result = (x * tmp * tmp) % 1000000007;
	}
	else
	{
		result = (tmp * tmp) % 1000000007;
	}

	return result;
}
int main()
{
	long long T,n;
	scanf("%lld", &T);
	while(T--)	
	{		
		scanf("%lld", &n);
		if (n == 1)
		{
			printf("0\n");
			continue;
		}
		printf("%lld\n",mypow(2,n-1)% 1000000007-1);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值