寻找最小数

E - A Magic Lamp HDU 3183

Time Limit: 1000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?

Input

There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.

Output

For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.

Sample Input

178543 4 
1000001 1
100001 2
12345 2
54321 2

Sample Output

13
1
0
123
321
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    char m[1000];
    char b[1000];
    int k,l,j,i;
    while(scanf("%s %d",&m,&k)!=-1)
    {
        l=strlen(m);
        int sum=0,t=0;
        j=l-k;
        while(j--)
        {
            int d=sum;
            for(i=sum+1; i<l-j; i++)
            {
                if(m[i]<m[d])
                {
                    d=i;
                }
            }
            b[t++]=m[d];
            sum=d+1;
            b[t]='\0';
        }
        int o=0;
        while(b[o]=='0'&&o<l-k)//找前面的0有多少个
        {
            o++;
        }
        if(o==l-k)//如果前面的0有l-k个就直接输出0
        {
            printf("0\n");
        }
        else
        {
            for(int z=o; z<l-k; z++)
            {
                printf("%c",b[z]);
            }
            printf("\n");
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值