Cleaning Shifts

W - Cleaning Shifts
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
所有的活必须在1~T天里完成,每头牛可以 再a[i].begain~a[i].end时间内干活,现将活安排给牛去做,尽量安排最少的牛去完成。
题意:给出区间[ 1,T ]和N个小区间,要求用尽可能少的小区间覆盖区间[ 1,T ],输出最少的小区间数量;若不能覆盖,输出-1。

贪心问题的典型例子,最小区间覆盖问题:以每头牛开始的时间为标准,从小到大为牛排序。然后,对于没有找过的牛,选取begin小于Max且end大于Max的最大区间(牛),直到end>=T为止。

设t为当前所有已确定区间的最右端,那我们可以每次都取所有可选的小区间(左端点<=t+1)中右端点最大的值,然后更新最右端点ans++。

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
    int a,b;
} s[26000];
bool cmp(node x,node y)
{
    if(x.a==y.a)
        return x.b<y.b;
    return x.a<y.a;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&s[i].a,&s[i].b);
        }
        sort(s,s+n,cmp);
        int sum=0;
        int l=0;
        int min,max=0;
        while(max<m)
        {
            min=max+1;
            for(int i=l; i<n; i++)
            {
               if(s[i].a<=min&&s[i].b>=min)
                    max=max>s[i].b?max:s[i].b;
                else if(s[i].a>min)
                {
                   l=i;
                    break;
                }
            }
            if(min>max)
               break;
            else
               sum++;
            }
        if(max>=m)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
}
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=26000;
struct node
{
    int x,y;
}a[MAXN];
int n,T;
bool cmp(node a,node b){return a.x<b.x;}
int main()
{
    scanf("%d%d",&n,&T);
    for (int i=0;i<n;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
    sort(a,a+n,cmp);
    a[n].x=0x7fffffff;
    int t=0,temp=0,ans=0;
    bool f=0;
    for (int i=0;i<n;i++)
        if (a[i].x<=t+1)
            {
                if (temp<a[i].y) temp=a[i].y,f=1;
                if (a[i+1].x>t+1 && f)
                    t=temp,++ans,f=0;
            }
    if (t<T) printf("-1\n"); else printf("%d\n",ans);
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值