数星星

数星星

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.


输入
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
输出
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
样例输入
5
1 1
5 1
7 1
3 3
5 5
样例输出
1
2
1
1
0
     
     
题意:给出一些星星的横坐标和纵坐标,而且星星的纵坐标按非递减排列,如果纵坐标相等,则横坐标按递增排列,任意两颗星星不会重合。如果有n颗星星的横坐标比某颗星星小而且纵坐标不大于那颗星星(即有n颗星星位于那颗星星的左下角或者左边)则此星星的等级为n,最后输出等级为0至n-1的星星的数量,也就是把相同等级的星星数目输出来。
     
     
分析:树状数组。题目给的数据按照y排序,相同的y按照x排序,这就给解题带来了很大的方便,我们可以按照由下至上、由左至右的顺序来处理数据,这样我们只利用x就可以进行计数了,因为当我们处理到任意点p的时候,所有的y小于p的点我们已经计数过了,只需要统计所有x不超过p的点的数量就可以了。由于星星的坐标是按y的递增给出的,那么就只需考虑水平方向,如果给出一个星星的坐标为(x,y),那么它的等级就等于前面已经输入的x坐标在[0,x]区间的星星数量
     
     
     
     
由于x可能取0,而lowbit(0)=0,故add(0,1)会死循环。这就是为什么TLE的原因。所以将所有的 x++.
#include<stdio.h>
#include<string.h>
#define maxx 40000
int c[40000],c1[40000];
int lowbit(int x)
{
    return x&-x;
}
void add(int pos,int num)
{
    while(pos<maxx)
    {
        c[pos]+=num;
        pos+=lowbit(pos);
    }
}
int we(int pos)
{
    int su=0;
    while(pos>0)
    {
        su+=c[pos];
        pos-=lowbit(pos);
    }
    return su;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=-1)
    {
        memset(c,0,sizeof(c));
        memset(c1,0,sizeof(c1));
        int x,y;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            x++;<span class="comment">//注意加1,不然会在add(0,1)处死循环</span><span> </span>
            c1[we(x)]++;
            add(x,1);
        }
        for(int i=0;i<n;i++)
        {
            printf("%d\n",c1[i]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值