Matrices with XOR property

Imagine A is a NxM matrix with two basic properties


1) Each element in the matrix is distinct and lies in the range of 1<=A[i][j]<=(N*M)

2) For any two cells of the matrix, (i1,j1) and (i2,j2), if (i1^j1) > (i2^j2) then A[i1][j1] > A[i2][j2] ,where 

1 ≤ i1,i2 ≤ N

1 ≤ j1,j2 ≤ M.

^ is Bitwise XOR


Given N and M , you have to calculatethe total number of matrices of size N x M which have both the properties

mentioned above.  


Input format:

First line contains T, the number of test cases. 2*T lines follow with N on the first line and M on the second, representing the number of rows and columns respectively.


Output format:

Output the total number of such matrices of size N x M. Since, this answer can be large, output it modulo 10^9+7


Constraints:

1 ≤ N,M,T ≤ 1000


SAMPLE INPUT 

1

2

2

SAMPLE OUTPUT 

4

Explanation

The four possible matrices are:

[1 3] | [2 3] | [1 4] | [2 4]

[4 2] | [4 1] | [3 2] | [3 1]

题意:找出有多少个排列矩阵  使得下标i1^j1>j2^j2  对应的元素也为a[i1][j1]>a[i2][j2]

排列矩阵是包含1-n*m每个数的矩阵

题解:先考虑一个矩阵n*m的答案,我们只要把i^j相同的位置做排列就行了。因为他们两个的大小没法比,所以可以排列。因为i^j<=1024  所以记录数字的多少开1024即可。然后考虑t个n*m,我们可以处理出行的前缀和

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<deque>
using namespace std;
typedef long long ll;
ll f[1200],sum[1005][1050],vis[1050];
int main()
{
    ll i,j,t,n,m;
    f[0]=1;
    for(i=1; i<=1024; i++)//计算排列的种类,例如总共有3个地方i^j相同的,总共有几种排列方法,那就是上一个的排列方法*3
    {
        f[i]=f[i-1]*i%1000000007;
    }
    for(i=1; i<=1000; i++)//计算到最后一行的时候,每一种相同的i^j的个数
    {
        for(j=1; j<=1000; j++)
        {
            sum[i][i^j]++;
        }
        for(j=0; j<=1024; j++)
            sum[i][j]+=sum[i-1][j];
    }
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&m);
        memset(vis,0,sizeof(vis));
        ll ans=1;
            for(i=0; i<=1024; i++)//到第n行时,把每一种i^j的数量赋值给vis
                vis[i]=sum[n][i];
            for(i=1; i<=n; i++)//因为我们vis【i】存的是n=n,m=1000,每种i^j的总个数,但是我们求得时候是用的n,m《=1000,所以只需要把总的渐去后面的就是当前的
            {
                for(j=m+1; j<=1000; j++)
                {
                    vis[i^j]--;
                }
            }
        for(i=0; i<=1024; i++)//求总的情况
        ans=ans*f[vis[i]]%1000000007;
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值