很麻煩的題

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
100
Sample Output

4203968145672990846840663646Note:No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

知道用字符串作加法的这个肯定能懂,从左到右一位一位地加,题目中说答案不会超过2005个数字,而我一个int 存了8位,所以可以确定数组的第二维最多开个255就行,而1维嘛,10的2006次方大约等于2的7000多次方,所以开个8000足够;
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
int a[8000][255]={{0}};
int main()
{
    for(int i=1;i<=4;i++)
    {
        a[i][1]=1;
    }
    for(int i=5;i<8000;i++)
    {
        for(int j=1;j<255;j++)
        {
            a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            a[i][j+1]+=a[i][j]/100000000;
            a[i][j]=a[i][j]%100000000;
        }
    }
    int n;
    while(scanf("%d",&n)!=-1)
    {
        int i;
      for(i=254;i>=1;i--)
      {
          if(a[n][i]>0)//去除前导0
          {
              break;
          }
      }
      printf("%d",a[n][i]);
      for(int j=i-1;j>=1;j--)
      {
          printf("%.8d",a[n][j]);
      }
      printf("\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值