Great Atm

Great Atm
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 37(11 users)Total Accepted: 10(8 users)Rating: Special Judge: No
Description
An old story said the evil dragon wasn’t evil at all, only bewitched, and now that the riddles were solved it was proving to be as kind as its new master.
A powerful warrior Atm is going to solve the riddles. First, he should beat the evil wizard. The road from Atm’s castle to wizard’s lab is filled with magic traps. The magic trap will affect Atm’s combat effectiveness.
Atm’s combat effectiveness can be considered as an integer. Effect of magic trap can be considered as mathematical operation. The three kinds of magic traps correspond to three kind of bit operation. (AND, OR and XOR)
Atm can adjust his equipment to change his initial combat effectiveness from 0 to m (include 0 and m). He wants when he arrives the wizard’s lab, his combat effectiveness can be maximum.
Input
There are multiple test cases.
For each test cases:
The first line contains two integers n(1<=n<=10^5) and m(1<=m<=10^9), indicating the number of magic traps and the maximum of initial combat effectiveness.
Each of the next n lines contains a string and an integer, indicating the bit operation. The string will be “AND”, “OR” or “XOR” correspond to AND operation (&), OR operation (|) or XOR operation (^). The integer t(1<=t<=10^9) is second operand in the operation.

Output
For each test cases, a line contains an integer, indicating the maximum combat effectiveness when he arrives the wizard's lab.
Sample Input
3 10
AND 5
OR 6
XOR 7
Sample Output
1
Source

"尚学堂杯"哈尔滨理工大学第七届程序设计竞赛

题意就是,让你从0~m中找一个数,使得经过一系列(&|,^)的操作后得的结果最大

思路:直接看m,m-1,m-2这几个数经过操作后得值,找最大值就好了

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int ha[10];
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        char a[10];
        int t;
        memset(ha,0,sizeof(ha));
        int p=0;
        for(int i=0;i<=2;i++)
        {
            ha[i]=m-i;
        }
        for(int i=0; i<n; i++)
        {
            scanf("%s%d",a,&t);
            if(a[0]=='A')
            {
                for(int i=0; i<=2; i++)
                {
                    ha[i]&=t;
                }
            }
            else if(a[0]=='O')
            {
                for(int i=0; i<=2; i++)
                {
                    ha[i]|=t;
                }
            }
            else
            {
                for(int i=0; i<=2; i++)
                {
                    ha[i]^=t;
                }
            }
        }
        sort(ha,ha+2,cmp);
        printf("%d\n",ha[0]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值