Kids’ Riddle

问题 B: Kids’ Riddle

时间限制: 1 Sec   内存限制: 512 MB
提交: 31   解决: 8
[ 提交][ 状态][ 讨论版]

题目描述

Friends, have you ever taken the April Fools Contest 2017 at Codeforces? There is a problem called Kids’ Riddle. The problem description is given below: Programmers’ kids solve this riddle in 5 to 10 minutes. How fast can you do it? After long time thinking, the authors of our problem found out the rule. Just count the number of holes in hexadecimal notation. And now, it becomes the problem to you. Please solve the Kids’ Riddle problem. 

输入

The input contains a single integer n(0 ≤ n ≤ 2000000000). 

输出

Output a single integer.

样例输入

61441

样例输出

2

提示

The hexadecimal notation of 61441 is F001, there are two holes in it. 


就是让你找这个数十六进制下的圈的个数
#include <bits/stdc++.h>
using namespace std;
int a[16] = { 1,0,0,0,1,0,1,0,2,1,1,2,0,1,0,0 };
int main()
{
	int n;
	while(~scanf("%d", &n))
	{
		int cnt = a[n % 16];
		n /= 16;
		while (n)
		{
			cnt += a[n % 16];
			n /= 16;
		}
		printf("%d\n", cnt);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值