SpringBoot 多数据源 java.lang.IllegalArgumentException: At least one JPA metamodel must be present!

java.lang.IllegalArgumentException: At least one JPA metamodel must be present!

启动类Application加上

@EnableAutoConfiguration(exclude={    
      JpaRepositoriesAutoConfiguration.class //禁止springboot自动加载持久化bean  
        })   

即可解决
最近刚刚完成数据库的多数据源的项目,也是踩了很多坑,不过也填了很多坑,哈哈。

阅读更多
个人分类: Spring Boot
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭