安装mysql时提示下列软件包有未满足的依赖关系

当遇到下面错误:

huangcd@huangcd-ubuntu:~$ sudo apt-get install mysql-server mysql-client正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 mysql-client : 依赖: mysql-client-5.5 但是它将不会被安装
 mysql-server : 依赖: mysql-server-5.5 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

 

 

解决:

先安装:

 sudo apt-get install mysql-client-core-5.5
阅读更多
个人分类: 每日一记
想对作者说点什么? 我来说一句

Mysql依赖jar包

2017年11月20日 3.28MB 下载

mysql安装所需要的一些依赖包

2013年07月15日 16.71MB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭