“福”字倒着贴,寓意“福到”。不论到底算不算民俗,本题且请你编写程序,把各种汉字倒过来输出。这里要处理的每个汉字是由一个 N × N 的网格组成的,网格中的元素或者为字符 @ 或者为空格。而倒过来的汉字所用的字符由裁判指定。
输入格式:
输入在第一行中给出倒过来的汉字所用的字符、以及网格的规模 N (不超过100的正整数),其间以 1 个空格分隔;随后 N 行,每行给出 N 个字符,或者为 @ 或者为空格。
输出格式:
输出倒置的网格,如样例所示。但是,如果这个字正过来倒过去是一样的,就先输出bu yong dao le,然后再用输入指定的字符将其输出。
输入样例 1:
$ 9
@ @@@@@
@@@ @@@
@ @ @
@@@ @@@
@@@ @@@@@
@@@ @ @ @
@@@ @@@@@
@ @ @ @
@ @@@@@
输出样例 1:
$$$$$ $
$ $ $ $
$$$$$ $$$
$ $ $ $$$
$$$$$ $$$
$$$ $$$
$ $ $
$$$ $$$
$$$$$ $
输入样例 2:
& 3
@@@
@
@@@
输出样例 2:
bu yong dao le
&&&
&
&&&
题解:
#include<iostream>
#include<stack>
using namespace std;
int main()
{
char map[110][110],dmap[110][110];
int n,flag=1;
char x,y;
stack<char>s;
cin>>x>>n;
cin.get();
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cin.get(map[i][j]);
// cout<<"i="<<i<<" j="<<j<<" n="<<n<<" map[i][j]="<<map[i][j]<<"0"<<endl;
if(map[i][j]!=' ')
s.push(x);
else
s.push(map[i][j]);
}
cin.get();
}
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
dmap[i][j]=s.top();
s.pop();
// cout<<flag<<endl;
// cout<<dmap[i][j]<<"!!"<<map[i][j]<<flag<<endl;
// if(dmap[i][j]!=' '&&map[i][n-1-j]!=' ')cout<<"yes";
// if(dmap[i][j]==map[i][n-1-j])cout<<"yes"<<endl;
if(!((dmap[i][j]!=' '&&map[i][n-1-j]!=' ')||(dmap[i][j]==map[i][n-1-j]&&map[i][j]==' ')))
{
flag=0;
}
}
}
if(flag==1)
cout<<"bu yong dao le"<<endl;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cout<<dmap[i][j];
}
cout<<endl;
}
return 0;
}