1004 Counting Leaves (30 分)——resolve

该程序接收家族树的节点信息,计算并输出从根节点开始每一层级的无子节点成员数量。输入包含树的节点数和非叶节点数,接着列出每个非叶节点及其子节点。示例中,树有两个节点,根节点01有一个子节点02。程序首先判断节点是否有子节点,然后计算每个层级的叶节点数,最终按层级顺序输出结果。
摘要由CSDN通过智能技术生成

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

代码如下:

#include<stdio.h>
#define MAXLEN 105
int n,m;
int father[MAXLEN];///mark father node of every child node
int leaf[MAXLEN];///the leaf number of every level 
int level;///the level of pidigree tree
/**
	judge if node have child,if have return 1,or return 0
*/
int judge_child(int node){
	int i;
	for(i=2;i<=n;i++){
		if(father[i]==node){
			return 1;
		}
	}
	return 0;
} 
/**
	count which level the node belongs to,then return the level of node
*/
int count_level(int node) {
	int l=2;
	int id=father[node];///the father node of this node 
	while(id!=1){
		l++;
		id=father[id];
	}
	return l;
}
/**
	count the number of leaf of every level
*/
void count_leaf(){
	int i;
	///init of leaf number of every level ,suppose the number of level is n
	for(i=1;i<=n;i++){
		leaf[i]=0;
	}
	///count leaf number 
	for(i=2;i<=n;i++){
		int l=count_level(i);
		if(judge_child(i)==0){
			leaf[l]++;
		}
		if(l>level){
			level=l;
		}
		///printf("%d\n",l);
	}
}
int main(){
	scanf("%d %d",&n,&m);
	/**
		test point 2 :
		If m==0,means every node is the root node
	*/
	if(m==0){ 
		printf("1");
		return 0;
	}
	int i,j,k,id_r,id_c;
	father[1]=1;
	for(i=0;i<m;i++){
		scanf("%d %d",&id_r,&k);
		for(j=0;j<k;j++){
			scanf("%d",&id_c);
			father[id_c]=id_r;
		}
	} 
	///for(i=1;i<=n;i++)
		///printf("%d ",father[i]);
	///for(i=2;i<=n;i++)
		///printf("%d\n",count_level(i));
	level=1;///init of level
	count_leaf();
	for(i=1;i<=level;i++){
		if(i==1){
			printf("%d",leaf[i]);
		}else{
			printf(" %d",leaf[i]);
		}
	}
	
	return 0;
} 
/**
	test case 1:
	7 3
	1 2 2 3
	2 2 4 5
	3 2 6 7
	test case 2:
	1 0
*/

结果如下: 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值