1410221224-hd-Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7857    Accepted Submission(s): 2553


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.

Output
For each case, output the result in a line.

Sample Input
  
  
100

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
题目大意
       这是斐波那契数的拓展。
解题思路
       这一方面用到了斐波那契数列,另一方面又需要大数加减法。
错误原因
       数组过大超过内存。可以将数组形式改为char型,这样可以减少四分之一的内存。
代码
#include<stdio.h>
#include<string.h>
char num[10000][2010];
//用int型会超出内存,所以该用char型 
int len[10000];//记录每个的长度 
int main()
{
	int n;
	int i,j,k;
	int a,b;
	for(i=1;i<10000;i++)
	    for(j=0;j<2010;j++)
	        num[i][j]='0';//初始化 
	num[1][0]='1';
	num[2][0]='1';
	num[3][0]='1';
	num[4][0]='1';
	len[1]=len[2]=len[3]=len[4]=1;
	a=0;
	for(i=5;i<10000;i++)
	{
		b=0;
		for(j=0;j<=len[i-1];j++)
		{
			b=a+num[i-1][j]-'0'+num[i-2][j]-'0'+num[i-3][j]-'0'+num[i-4][j]-'0';
			num[i][j]=b%10+'0';
			a=b/10;
		}//大数加减法 
		if(num[i][len[i-1]]!='0')
		    len[i]=len[i-1]+1;
		else
		    len[i]=len[i-1];
		if(len[i]>2005)
		    break;
	}
	while(scanf("%d",&n)!=EOF)
	{
		for(i=len[n]-1;i>=0;i--)
		    printf("%c",num[n][i]);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值