1410282310-hd-Seinfeld



Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1413    Accepted Submission(s): 697


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
  
  
}{ {}{}{} {{{} ---
 

Sample Output
  
  
1. 2 2. 0 3. 1
 题目大意
        有一堆括号,{}这样算配对,{{,}},}{这样都算不配对,对于一组不配对的括号,可以通过变化括号的方向来使其配对,变一个算一次,求最少的变化次数。
解题思路
       对于{}这种情况,可以将其略去。这样不配对的括号组可以有以下三种情况1.{{{{2.}}}}3.}}}}{{{{当然也可以合并为一种情况n...}{...m。对于}}或者{{只需改变一次,而对于}{则须改变两次。
      这道题主要用到了栈的知识。
代码
#include<stdio.h>
#include<string.h>
char s[2200],c[2200];
int main()
{
	int len1,len2,len3;
	int i,j,k=1;
	int sum,top;
	while(scanf("%s",s)&&s[0]!='-')
	{
		len1=strlen(s);
		top=1;
		memset(c,0,sizeof(c)); 
		c[0]=s[0];
		for(i=1;i<len1;i++)
		{
			c[top]=s[i];
			//if(s[i-1]=='{'&&s[i]=='}')   错误之处 
			//测试数据{{}}
			if(c[top-1]=='{'&&c[top]=='}')
			//是否入栈是让栈组比较的。 
			    top--;
			else
				top++;
		}
		len2=0;
		for(i=0;i<top;i++)
		{
		    if(c[i]=='}')
		        len2++;
		    else
		        break;
		}
		len3=top-len2;
		/*if(len1%2==0)
		    sum=len1/2+len2/2;
		else
		    sum=len1/2+len2/2+2; 
		这样判断的话要额外考虑栈为空的情况*/ 
		sum=(len2+1)/2+(len3+1)/2;
		printf("%d. ",k);
		k++;
		printf("%d\n",sum);
	}
	return 0;
} 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个子系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值