1411171038-hd-Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31785    Accepted Submission(s): 13082


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

 题目大意
         有一个骨头收藏家,他有一个容量为V的容器来收藏骨头。现在有N个骨头

各个骨头的价值为v[i],各个骨头所占容量为w[i]。问他在容量为V的容器里,最多能

收藏总价值为多少的骨头?

解题思路

       这是一道简单的01背包问题。特征是有N件物品和一个容量为V 的背包。放入第i件物品耗费的空间是C[ i ],得到
的价值是W[ i ]。求解将哪些物品装入背包可使价值总和最大。

       每种物品仅有一件,可以选择放或不放。用子问题定义状态:即F[i,v]表示前i件物品恰放入一个容量为v的背包可以得的最大价值。则其状态转移方程便是:

                     F[i,v] = max { F[i - 1,v],F[i - 1,v - C[ i ] ] + W[ i ] }

        优化过后就是f[v]=max(f[v],f[v-c[i]]+w[i])

代码

#include<stdio.h>
#include<string.h>
int tiji[1100],jiazhi[1100];
int dp[1100];
int maxnum(int a,int b)
{
	if(a>b)
	    return a;
	else
	    return b;
}
int main()
{
	int n;
	int num,max;
	int i,j,k;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&num,&max);
		for(i=1;i<=num;i++)
		    scanf("%d",&jiazhi[i]);
		for(i=1;i<=num;i++)
		    scanf("%d",&tiji[i]);
		memset(dp,0,sizeof(dp));//因为题目要求价值最高,不考虑是不是恰好装满,所以全部初始化为0就好 
		for(i=1;i<=num;i++)
		    for(j=max;j>=tiji[i];j--)
		        dp[j]=maxnum(dp[j],dp[j-tiji[i]]+jiazhi[i]);
		        //可以根据这个方程自己模拟一遍 
		printf("%d\n",dp[max]);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值