hdoj 1536 题目大意 SG函数 博弈

Hdoj 1536

 

Problem Description

 

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

 

 

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

 

  The players take turns chosing a heap and removing a positive number of beads from it.

 

  The first player not able to make a move, loses.

 

 

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

 

 

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

 

  If the xor-sum is 0, too bad, you will lose.

 

  Otherwise, move such that the xor-sum becomes 0. This is always possible.

 

 

It is quite easy to convince oneself that this works. Consider these facts:

 

  The player that takes the last bead wins.

 

  After the winning player's last move the xor-sum will be 0.

 

  The xor-sum will change after every move.

 

 

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

 

 

Input

 

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

 

Output

 

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

Sample Input

 

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

 

Sample Output

 

LWW                             
WWL

来自 <http://acm.hdu.edu.cn/showproblem.php?pid=1536

题目大意就是先给出一个拿的规则,例如:2,5。那么你就只能一次拿走2个或5个。第一输入的数就是描述这个规则有几个数,例如:3,证明这个规则有三个数,然后紧接着输入三个数。然后下一行输入一个数是限定在这个拿取规则下有几组测试。然后接下来就是输入这几组测试数据。一行为一组。一行的开头先输入一个数据,是描述这个组有多少个数据,然后紧接着输入这么多个数据。然后你可以从这些数据中任选一个拿走符合规则大小的数,谁先没有数可以拿了,谁就输了。

例如输入:3 1 2 3 //规则为 只能一次拿 1 或 2 或 3;

          3       //在这个规则下有三组测试数据

          2 3 5   (//第一组 这组有两个数据,你可以从 3 5 中任意选一个数,              

                  //然后从中拿走 1 或 2 或 3;拿到最后当对手没有数可以             

                  //拿的时候你就赢了。)

          3 4 6 8  //第二组数据

          5 2 3 7 9 12  //第三组数据

解题思路:

这道题是一个典型的SG函数应用题,将规则记录进一个数组,然后将在这个规则下的0-10000(最好是10005)的SG值都计算出来,然后再将测试组里的数据的SG值异或起来 例如第一组数据中的SG   2 3 5  , 就将SG[3]^SG[5],判断这个值是否为零,如果为零则 输出 “L”否则输出“W” 。

 

不会SG的可以参考一下这个链接:

https://blog.csdn.net/strangedbly/article/details/51137432

 

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
bool S[10005];
int F[105],SG[10005];
void getSG(int n)//注意控制循环的条件,否者会出错 。 
{
	int i,j;
	memset(SG,0,sizeof(SG));
	for(i=1;i<10005;i++){
		memset(S,0,sizeof(S));
		for(j=0;j<n&&F[j]<=i;j++){//注意循环的条件否者SG函数的计算会出错。 
			S[SG[i-F[j]]]=1;//对该点孩子节点的SG值进行标记。 
		}
		for(int k=0;;k++)if(!S[k]){
			SG[i]=k;  //找出最小的不属于这个集合的值作为这个点的SG值。 
			break;
		}
	}
} 
int main()
{
	int k,m,l,sum,a;
	while(~scanf("%d",&k)&&k){
		for(int i=0;i<k;i++)
			scanf("%d",&F[i]);
			sort(F,F+k);
				getSG(k);
			//	for(int i=0;i<100;i++)
			//	printf("%d\n",SG[i]);
				scanf("%d",&m);
				for(int i=0;i<m;i++){
					sum=0;
					scanf("%d",&l);
					for(int j=0;j<l;j++){
						scanf("%d",&a);
						sum^=SG[a];
					}
					if(sum)
					printf("W");
					else
					printf("L");
				}
					printf("\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值