HDU 1004

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62684    Accepted Submission(s): 23105


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
      
      
5 green red blue red red 3 pink orange pink 0
 

Sample Output
      
      
red pink
 



   这是一道 支付串相关 的题 主要用到 strcmp  函数进行比较 返回值为1 时 说明两个字符串相同;

  算法思想:

               1、 用什么数据结构 ,用a[1000][15] 二位数组来存放字符串 这个很关键

               2.、思想主要就是 查找 用第一个开始查找有没有和他相同的 有的话 计数加1 并且要注意的是 查找到相同的数组记得删除 即可;

               3、其实一套主要的是 max 的赋值方法 开始 给Max 赋值一个较小的值 如果计数 的数大于 max 将其值付给 max  并且记录位置 然后继续往下走

源代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int main()
{
    char a[1000][15];
    int n, po;
    int i, j;
    while(cin>>n)
    {
        po = n;
        int maxm = 1;
        if(n == 0)
        {
            return 0;
        }
        for(i = 0; i < n; i++)
        {
            scanf("%s", a[i]);
        }

        for(i = 0; i < n; i++)
        {
           int coun = 1;        //开始时没注意 这个计数要在 for里面进行计数的
           if(a[i][0] == '\0') continue;
           for(j = i+1; j < n; j++)
           {
               if(strcmp(a[i], a[j]) == 0)
               {
                  coun++;
                  a[j][0] = '\0';
               }

           }
           if(maxm <= coun)
           {
               maxm = coun;
               po = i;
           }

        }
        puts(a[po]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wangxiaoming

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值