HDU 1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 89480    Accepted Submission(s): 21333


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
      
      
1 1 3 1 2 10 0 0 0
 

Sample Output
      
      
2 5


这个题 最怕的就是超时 对于这个问题,还有待解决:

先附上一段超时代码:

#include<iostream>
using namespace std;

int f(int a, int b, int n)
{
    if(n == 1 )
     return 1;
    else if(n == 2)
    return 1;
    else return (a*f(a , b,n - 1) + b*f(a, b,n - 2))%7 ;
}
int main()
{
    int a, b, n;
    while(cin>>a>>b>>n)
    {
        if(a == 0 && b == 0 && n ==0)
        {
             return 0;
        }
        cout<<f(a, b, n)<<endl;
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wangxiaoming

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值