每日AC--POJ 1458 Common Subsequence -DP



Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54754 Accepted: 22811

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0










import java.util.Scanner;


/**
 * 类说明
 * 
 * <pre>
 * Modify Information:
 * Author        Date          Description
 * ============ =========== ============================
 * DELL          2017年8月2日    Create this file
 * </pre>
 * 
 */

public class Main {
 
    /**
     * 最长公共子序列问题, 给定 两个字符串 求 这两个字符串的公共子序列
     * 确认这个公式很重要.
     * 
     * 动态规划问题:
     *  dp[i+1][j+1] = {
     *                   dp[i][j] +1,  dp[i][j+1], dp[j+1][i]  //
     *                   dp[i+1][j] ,dp[i][j+1]
     *                   }
     */
    public int getLongestCommonString(String str1, String str2){
        
        int[][]  dp = new int[str1.length()+1][str2.length()+1];
        char[] strChar1 = str1.toCharArray();
        char[] strChar2 = str2.toCharArray();
       
        for(int i = 0; i < strChar1.length; i++){
            for(int j = 0; j < strChar2.length; j++){
                if(strChar1[i] == strChar2[j]){
                    dp[i+1][j+1] =  dp[i][j] +1;
                }else{
                    dp[i+1][j+1] = Math.max(dp[i+1][j], dp[i][j+1]);
                }
            }
        }
        return dp[str1.length()][str2.length()];
    }
    
    /**
     * @param args
     */
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        String str1 = "addadbs";
        String str2 ="hdgsfvab";
        
        String str3 = "abcfbc";
        String str4 ="abfcab";
        
        Scanner cin = new Scanner(System.in);
        String str5 = "";
        String str6 = "";
        
        while(cin.hasNext()){
            str5 = cin.next();
            str6 = cin.next();
            int ans = new Main().getLongestCommonString(str5, str6);
            System.out.println(ans);
        }
         
    }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wangxiaoming

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值