python列表作业 1.两行合并去重 2.绝对值排序

python列表作业

1. input two lists :alist and blist,members of each list are of integer decimals and no more than 10;
merge alist and blist as a new list clist, in which duplicate elements are eliminated。
A list can be inputted as follows:

alist=list(map(int,input().split()))

to ensure the output is consistent, please output the elements of the new list in sequence,which can be accomplished as sorted(alist)。

Input format:
Two lines are typed, each line is used to input a list, list members are separated by space。
Output format:
One line is outputted as list。
Input example:
1 2 3
4 3 2
Output example:
[1,2,3,4]
#两行变一行,加去重
alist=list(map(int,input().split()))
blist=list(map(int,input().split()))
print(sorted(list(set(alist+blist))))

没有把输入限制在10以内,不

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值