PAT A 1010. Radix (25)

1 篇文章 0 订阅
1 篇文章 0 订阅

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
// 题目分析:
该题目坑点较多,需要仔细分析:
1.明确进制取值的上下限,下限为各位数字的最大值+1,上限可为已知的数字,之后就可以采用二分法进行寻找;
2.按照题目要求,有多种进制满足要求时取最小的进制,事实上,这种情况只会出现在只有一位数字的情况下,要单独分析;
3.十位数字,要用long long int;
4.当进制过大时,long long int 也超出范围,此时数字表现为小于零,一旦出现这种情况需要判断出是进制取值过大了;
// 代码
#include <iostream>
using namespace std;
long long int getNum(char *n1,int radix){
  int i=0;
  long long int num1=0;
  while(n1[i]){
    int dig;
    if(n1[i]>='0'&&n1[i]<='9'){
      dig=n1[i]-'0';
    }else{
      dig=n1[i]-'a'+10;
    }
    num1=num1*radix+dig;
    i++;
  }
  return num1;
}
int getRadix(char *n1,char *n2,int radix){
  long long int num1=getNum(n1,radix);
  long long int num2;
  
  int i=0;
  long long int min=1;
  while(n2[i]){
    int dig;
    if(n2[i]>='0'&&n2[i]<='9'){
      dig=n2[i]-'0';
    }else{
      dig=n2[i]-'a'+10;
    }
    if(dig>min)
      min=dig;
    i++;
  }
  min++;
  long long int left=min;
  long long int right=num1;
  num2=getNum(n2,left);
  if(num2==num1)
    return left;
  if(i<=1)
    return -1;
  while(left<=right){
    long long int mid=(left+right)/2;
    num2=getNum(n2,mid);
    if(num2==num1)
      return mid;
    else if(num2<0||num2>num1)
      right=mid-1;
    else
      left=mid+1;
  }  
  return -1;
}

int main(){
  char n1[11],n2[11];
  int tag,radix;
  scanf("%s%s",n1,n2);
  cin>>tag>>radix;
  int r;
  if(tag==1)
    r=getRadix(n1,n2,radix);
  else
    r=getRadix(n2,n1,radix);
  if(r==-1)
    cout<<"Impossible";
  else
    cout<<r;
  system("pause");
  return 0;
}
// 结果


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值