6.7 问题 A: 简单计算器

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入 Copy

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出 Copy

12178.21

解题思路:

1.中缀表达式转后缀表达式

2.计算后缀表达式

#include <iostream>
#include <cstdio>
#include <queue>
#include <stack>
#include <map>
using namespace std;
struct node
{
    double data;
    char ch;
    int flag;
};
queue <node> q;
stack <node> s;
map<char,int> m;
string str;
void init()
{
    while(!s.empty()) s.pop();
}
void change()///中缀转后缀
{
    node t;
    int n=str.size();
    double cnt=0.0;
    for(int i=0;i<n;i++){
        if(str[i]>='0'&&str[i]<='9'){
            cnt=cnt*10+str[i]-'0';
        }
        else if(str[i]!=' '){
            t.flag=1;
            t.data=cnt;
            q.push(t);
            cnt=0.0;
            while(!s.empty()&&m[s.top().ch]>=m[str[i]]){
                    q.push(s.top());
                    s.pop();
            }
            t.flag=0;
            t.ch=str[i];
            s.push(t);
        }
    }
    t.flag=1;
    t.data=cnt;
    q.push(t);
    while(!s.empty()){
        q.push(s.top());
        s.pop();
    }
}
void cal()///计算后缀表达式的值
{
    node t;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t.flag==1) s.push(t);
        else{
            node x=s.top();s.pop();
            node y=s.top();s.pop();
            if(t.ch=='*') y.data*=x.data;
            if(t.ch=='/') y.data/=x.data;
            if(t.ch=='+') y.data+=x.data;
            if(t.ch=='-') y.data-=x.data;
            s.push(y);
        }
    }
    double ans=s.top().data;
    printf("%.2lf\n",ans);
}
int main()
{
    m['+']=1;m['-']=1;
    m['*']=2;m['/']=2;
    while(getline(cin,str),str!="0"){
        init();
        change();
        cal();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值