poj 1394 Minimum Inversion Number

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 
本题就是求循环移位后逆序数的最小值。
其实主要就是求序列的逆序数。
逆序数的求法很多,可以用归并排序求。
也可以用树状数组和线段树求逆序数。
 最近在写树状数组的题目,所以用树状数组写的
逆序数求得之后,把第一个数移到最后的逆序数是可以直接得到的。
比如原来的逆序数是ans,把a[1](输入从1开始)移到最后后,减少逆序数a[1],同时增加逆序数n-1-a[1]个,如果觉得不理解,自己在草稿纸上模拟模拟就明白了
就是ans-a[0]+n-a[0]-1;
 
只要i从1~n-1循环一遍取最小值就可以了。
代码如下,已AC
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int num[50001];
int C[50001];
int n;
int lowbit(int x)
{
	return x&(-x);
}
void Init()
{
	memset(C,0,sizeof(C));
	memset(num,0,sizeof(num));
}
void update(int x,int d)
{
	while(x<=n){
		C[x]+=d;
		x+=lowbit(x);
	}
}
int sum(int x)
{
	int ret=0;
	while(x>0){
		ret+=C[x];
		x-=lowbit(x);
	}
	return ret;
}
int main()
{
	while(scanf("%d",&n)!=EOF){
		Init();
		for(int i=1;i<=n;i++){
			scanf("%d",&num[i]);
		}
		int c;
		long res=0;
		for(int i=n;i>=1;i--){
			if(num[i]==0){
				c=i;
				continue;	
			}
			update(num[i],1);
			res+=sum(num[i]-1);
		}	
		res=res+c-1;//在0之前的数都是比0大的,所以都与0构成逆序对,需要加上 
		//printf("%ld\n",res);
		long min=res,tmp=res; 
		for(int i=1;i<=n-1;i++){
			tmp=tmp-num[i]+n-num[i]-1;
			if(tmp<min) min=tmp;
		}
		printf("%ld\n",min);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值