ACM杭电的1093求和问题

/*
时间:
	20120314
作者:
	烟大洋仔
题目:
	Problem DescriptionYour task is to calculate the sum of some integers.

InputInput contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

OutputFor each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input24 1 2 3 45 1 2 3 4 5 

Sample Output1015

题目分析:
	本题结合了之前做过的几个答题;
	一个是控制数据的组数;2是控制数据的输入个数;三是输出结果
	本题通过了三重循环;一重呢是输入组数的;二重是控制数据的计算的	个数的;三重呢就是控制输出结果的
*/
#include <iostream>
using namespace std;
int main()
{
    int n,m,a,sum=0;
    while(cin>>n)
    {
        while (n--)
        {
            cin>>m;
            sum=0;
            while(m--)
            {
                cin>>a;
                sum=sum+a;
            }
            cout<<sum<<endl;
        }


    }

    return 0;

}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值