Making the Grade(dp数组)

题目:Making the Grade

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + … + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

题意:

约翰的奶牛只想走单调的斜坡(斜向上或斜向下),现给你一个崎岖不平的坡,试增加或消减使其成为单调斜坡。

代码:

#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m,k,sum;
int dp[2021][2021];
int a[2021],b[2021],c[2021];
int main()
{
	int i,j;
    cin>>n;
    for(i=1;i<=n;i++)
    {
        cin>>a[i];
        b[i]=a[i];
    }
    sort(a+1,a+1+n);
    for(i=1;i<=n;i++)
    	dp[1][i]=abs(b[1]-a[i]);//算出绝对值
    for(i=1;i<=n;i++)
    {
        k=dp[i-1][1];
        for(j=1;j<=n;j++)
        {
            k=min(k,dp[i-1][j]);
            dp[i][j]=k+abs(a[j]-b[i]);//找较小的那个
        }
    }
    sum=dp[n][1];
    for(i=1;i<=n;i++)
        sum=min(sum,dp[n][i]);
    cout<<sum<<endl;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值