大小写转换(多实例输入)

读入一些字符串,将其中的小写字母转成大写字母(其他字符不变)。

输入
输入为多行,每行为一个字符串,字符串只由字母和数字组成,长度不超过80。输入以“End of file”结束。
输出
对于每行输入,输出转换后的字符串。

输入示例
Hello
ICPC2004
12345abcde
输出示例
HELLO
ICPC2004
12345ABCDE
提示
用“scanf("%s", str) == 1”这个条件可以判断输入是否结束。如果此条件为假,则输入结束(对于本题)。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cstdlib>
#include <algorithm>
#include<string.h>
#include<queue> 
#include<math.h>
#include<set>
#define llu unsigned long long
using namespace std;

int main()
{
	char s[85];
	while(scanf("%s",s) == 1)
	{
		int n=strlen(s);
		for(int i=0;i<n;i++)
			if(s[i]>='a'&&s[i]<='z')s[i]-=32;
		cout << s << endl ;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值