鞍山现场赛 hdu 5074- Hatsune Miku(DP)

去鞍山现场赛之前没接触过dp(说了是去打酱油的嘛~),回来本打算继续攻数论,caoyu学长建议我刷一两个月dp,说dp比较锻炼思维,于是放下手中的数论,先进军dp。

今天是第三天,昨天和前天做了4道dp题,今天上英语课无聊,想了想现场赛那道题,原来是到dp的大水题……唉,比赛前能稍微接触点dp思想也不至于那么惨了。


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5074


Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 313    Accepted Submission(s): 234


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

用w储存每个坐标的分数,c储存给的序列,dp[i][j]指序列中第i个数取j时的最大值。
可能现在写的dp有些烂,以后变强大后回来看看能不能有所改善 大笑

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int T,n,m;
int w[55][55],c[105],dp[105][55];
int maxx(int a,int b){
	return a>b?a:b;}

int main(){
	int i,j,t,ma;
	scanf("%d",&T);
	while(T--){
		memset(dp,0,sizeof(dp));
	scanf("%d%d",&n,&m);
	for(i=1;i<=m;i++)
	for(j=1;j<=m;j++)
	scanf("%d",&w[i][j]);
	for(i=1;i<=n;i++)
	scanf("%d",&c[i]);
	for(i=2;i<=n;i++){
	if(c[i-1]>0&&c[i]>0)
		dp[i][c[i]]=dp[i-1][c[i-1]]+w[c[i-1]][c[i]];
	else if(c[i-1]<0&&c[i]<0)
		for(j=1;j<=m;j++)
        for(t=1;t<=m;t++){
            dp[i][j]=maxx(dp[i][j],dp[i-1][t]+w[t][j]);
        }
    else if(c[i-1]<0&&c[i]>0)
        for(t=1;t<=m;t++)
            dp[i][c[i]]=maxx(dp[i][c[i]],dp[i-1][t]+w[t][c[i]]);
    else if(c[i-1]>0&&c[i]<0)
        for(j=1;j<=m;j++)
            dp[i][j]=dp[i-1][c[i-1]]+w[c[i-1]][j];
	}
	ma=0;
	for(i=1;i<=n;i++)
        if(dp[n][i]>ma)
            ma=dp[n][i];
    printf("%d\n",ma);
	}

	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值