ZOJ_1216_Deck

Deck

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Scenario

A single playing card can be placed on a table, carefully, so that the short edges of the card are parallel to the table's edge, and half the length of the card hangs over the edge of the table. If the card hung any further out, with its center of gravity off the table, it would fall off the table and flutter to the floor. The same reasoning applies if the card were placed on another card, rather than on a table. 

Two playing cards can be arranged, carefully, with short edges parallel to table edges, to extend 3/4 of a card length beyond the edge of the table. The top card hangs half a card length past the edge of the bottom card. The bottom card hangs with only 1/4 of its length past the table's edge. The center of gravity of the two cards combined lies just over the edge of the table.

Three playing cards can be arranged, with short edges parallel to table edges, and each card touching at most one other card, to extend 11/12 of a card length beyond the edge of the table. The top two cards extend 3/4 of a card length beyond the edge of the bottom card, and the bottom card extends only 1/6 over the table's edge; the center of gravity of the three cards lines over the edges of the table.

If you keep stacking cards so that the edges are aligned and every card has at most one card above it and one below it, how far out can 4 cards extend over the table's edge? Or 52 cards? Or 1000 cards? Or 99999?


Input

Input contains several nonnegative integers, one to a line. No integer exceeds 99999.


Output

The standard output will contain, on successful completion of the program, a heading: 

# Cards Overhang

(that's two spaces between the words) and, following, a line for each input integer giving the length of the longest overhang achievable with the given number of cards, measured in cardlengths, and rounded to the nearest thousandth. The length must be expressed with at least one digit before the decimal point and exactly three digits after it. The number of cards is right-justified in column 5, and the decimal points for the lengths lie in column 12.


Sample Input





30


Sample Output

The line of digits is intended to guide you in proper output alignment, and is not part of the output that your solution should produce. 

12345678901234567 
# Cards  Overhang 
    1     0.500 
    2     0.750 
    3     0.917 
    4     1.042 
   30     1.997



题意和思路:这题关键是找规律。。我完全靠凑出来这个规律的,证明为何是这个规律就不知道了,如果哪位达人知道告诉下。最后注意输出格式就好。。找到规律就不难了。


Sample Program Here

/******************************************
**
**      Author: Wan KaiMing
**      Date:   2012-10-31-19.40
**
*******************************************/


#include<iostream>
#include<string>
#include<iomanip>
using namespace std;
int main(){
   int n;//表示牌的数量
   double s=0;//表示超出桌沿的距离
   cout<<"# Cards  Overhang\n";
   while(cin>>n){
     s=0;
     for(int i=1;i<=n;i++) s+=1.0/(2*i);
     cout<<setw(5)<<n
         <<setw(10)<<fixed<<setprecision(3)<<s<<endl;
   }

   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值