ZOJ_1292_Integer Inquiry

Integer Inquiry

Time Limit: 2 Seconds       Memory Limit: 65536 KB

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)


Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.


Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670




题意和思路:大数相加,首先肯定要接受字符串,然后就是自己模拟相加和进位了,注意些细节可以省略很多麻烦,比如sum[0]保存低位 这样进位直接前面的加1就好 方便很多 代码有注释 不需要多说了。之前写了个版本代码太长 后来重新写了个如下。

/******************************************
**
**      Author: Wan KaiMing
**      Date:   2012-11-04-21.24 星期日
**
*******************************************/



#include <iostream>
#include <string>
#include<cstring>
#define  MAX  105
using namespace std;

void addsum(int sum[],string s){
   int len = s.length();
   int t;//用于保存每个转化成数字的值
   for(int i=len-1;i>=0;--i){  //此处是i=len-1容易错 要知道数组从0开始
      t=s[i]-'0';
      if( (t+sum[len-1-i])>9 ){   //此处的处理时s从后面开始处理,保存的时候sum[0]保存最低位(建议) 如果保存最高位 每次长度不同 位置不好处理
       sum[len-1-i]=(t+sum[len-1-i])%10;
       sum[len-i]++;
      }
      else sum[len-1-i]+=t;
   }
}

int main(){
   string s[MAX];
   int n=0;
   int sum[MAX]={0};
   cin>>n;
   while(n--){
      int i=0;
      //处理相加
      while(cin>>s[i++]){
         if(s[i-1]=="0") break;
         addsum(sum,s[i-1]);
      }

      //确定输出的位置(将开头多余的0忽略)
      int pos=MAX-1;  //不要写成MAX要不然溢出了
      while(sum[pos]==0) pos--;

      //打印
      for(i=pos;i>=0;--i) cout<<sum[i];


      if(n==0)  cout<<endl;
      else cout<<endl<<endl;


	  //结束后初始化sum
	  memset(sum,0,sizeof(sum));
   }

  return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值