POJ-3617 Best Cow Line

Description
FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual”Farmer of the Year” competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input
* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A’..’Z’) of the cow in the ith position in the original line
Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’..’Z’) in the new line.
Sample Input
6
A
C
D
B
C
B
Sample Output
ABCBCD

做题学英文

1. phase
n.相,周相; 阶段; [物理学]相位; 方面,侧面;
vt.分阶段实行; 调整相位;
vi.分阶段进行;


2. lexicographic
adj.词典的,词典编辑的;


3. marshal
n.元帅; 典礼官; 执法官; 消防局长;
vt.整理,排列,集结;
vi.排列; 编队;

思路:很简单的一道题,假使我们将原始的字符串为S,我们不断寻找S的首尾中最小的元素添加到空字符串T,若首尾相同添加哪个呢?这时候我们比较首尾的下一个元素,添加小的一边首或尾元素,这样依次下去。

#include<iostream>
using namespace std;
int main(){
    int N,cnt=0;
    char S[2005];
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    scanf("%s",&S[i]); 
    int a=0,b=N-1;
    while(a<=b){
        bool left=false;
        for(int i=0;i<=(b-a)/2;i++){     //相同则比较下一对 
            if(S[a+i]<S[b-i]){  //左边小于右边,从左边取 
                left=true;
                break;
            }
            else if(S[a+i]>S[b-i]){     //右边小于左边,从右边取 
                left=false;
                break;
            }
        }
        if(left) putchar(S[a++]);
        else putchar(S[b--]);
        cnt++;              //计算字符个数 
        if(cnt==80)  
        {  
            putchar('\n');
            cnt=0;  
        }  
    }
    putchar('\n');
    return 0;
} 

题目链接:

http://poj.org/problem?id=3617

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值