C++:已知各顶点坐标求多边形面积

woj上的1213和1402题,给出顶点坐标求出多边形面积。

原理:

任意多边形的面积可由任意一点与多边形上依次两点连线构成的三角形矢量面积求和得出。

分析:
由于给出的点是相对于我们的坐标原点的坐标,每个点实际上我们可以当作一个顶点相对于原点的向量,如下图所示:
图片
P(0,0)对应的顶点向量分别为:A(x0,y0),B(x1,y1),…,G(x6,y6)
另外, PAB 的矢量面积即为

S⃗ PAB=12PAPB=12(XaYbXbYa)

且多边形面积为:

S=k=1nS⃗ PXY=12k=0n(XkYk+1Xk+1Yk)

根据上述公式可以直接求出多边形的代码从而避免了边长的复杂计算。


附上两个woj原题以及代码:

1213 area

Description
Give you a simple polygon, the border is plumb or aclinic. your task is calculate the area of the polygon.

Input
first line is n(n≤100)。following N lines contains X,Y, the vertexs show as counter-clockwise. -200≤x,y≤200。

Output
print the total area.

Sample Input
10
0 0
4 0
4 1
3 1
3 3
2 3
2 2
1 2
1 3
0 3

Sample Output
9

C++:

//
//  main.cpp
//  1213
//
//  Created by waple on 16/12/23.
//  Copyright © 2016年 waple. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, const char * argv[]) {
    int ncase;
    cin >> ncase;
    int x,y,x0,y0,sum = 0;
    cin >> x >> y;
    x0 = x;
    y0 = y;
    while (--ncase) {
        int xtmp,ytmp;
        cin >> xtmp >> ytmp;
        sum += (x*ytmp-y*xtmp);
        x = xtmp;
        y = ytmp;
    }
    sum += (x*y0-y*x0);
    printf("%d\n",int(abs(sum)/2));
    return 0;
}

1402 Build Your Home

Description
Mr. Tenant is going to buy a new house. In fact, he is going to buy a piece of land and build his new house on it. In order to decide which piece of land to buy, Mr. Tenant needs a program which will give a score to each piece. Each candidate piece of land is a polygonal shape (not necessarily convex), and Mr. Tenant wonders what the best score is. Among possible scores, he considered the number of vertices, sum of angles, minimum number of required guards, and so forth. Finally, Mr. Tenant decided that the best score for a piece of land would simply be its area. Your task is to write the desired scoring program.

Input
The input file consists of multiple pieces of land. Each piece is a simple polygon (that is, a polygon which does not intersect itself). A polygon description starts with a positive integer number k, followed by k vertices, where each vertex consists of two coordinates (floating-point numbers): x and y. Naturally, the last vertex is connected by an edge to the first vertex. Note that each polygon can be ordered either clockwise or counterclockwise. The input ends with a “0” (the number zero).

Output
For each piece of land, the output should consist of exactly one line containing the score of that piece, rounded to the nearest integer number. (Halves should be rounded up, but Mr. Tenant never faced such cases.) Hint: The scoring program has to handle well degenerate cases, such as, polygons with only one or two vertices.

Sample Input
1 123.45 67.890
3 0.001 0 1.999 0 0 2
5 10 10 10 12 11 11 12 12 12.0 10.0
0

Sample Output
0
2
3

C++:

//
//  main.cpp
//  1402
//
//  Created by waple on 16/12/23.
//  Copyright © 2016年 waple. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>

using namespace std;

int main(int argc, const char * argv[]) {
    int n;
    while(scanf("%d",&n) && n){
        double x,y,x0,y0,sum = 0.0;
        cin >> x >> y;
        x0 = x;
        y0 = y;
        while (--n) {
            double xtmp,ytmp;
            cin >> xtmp >> ytmp;
            sum += (x*ytmp-y*xtmp);
            x = xtmp;
            y = ytmp;
        }
        sum += (x*y0-y*x0);
        printf("%d\n",int(abs(sum)/2+0.5));
    }
    return 0;
}
  • 2
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值